Paltalk version 10

I try to play with version 10 Beta, the way to send text to room:
Call RoomSend(RichTextBox1.TextRTF) not working anymore
Version 10 only accept:
Call RoomSend(RichTextBox1.Text).
Anyone have some idea to fix this problem?

46 thoughts on “Paltalk version 10

  1. Just a suggestion, Why don’t you use the balool Interface to make your apps for paltalk, this will make it a lot easier to distribute your programs as a plugin and not have to worry about all the other stuff thats needed to send and receive text from paltalk, Balool is made in C# so it uses the .net frame work which means you can use vb.net to create your plugins. You can spend more time on making your apps and because of the interface you will have access to a lot more stuff

  2. Yes I have tried with UTF-8 and hebrew and both gave grbage on the screen both locally and remotely (self IM).
    In the edit box everything is fine but after send the IM text shows question marks.

  3. Thanks for the clarification Departure.

    winter, I was looking for the Paltalk download. Not a crack thereof.

    Up until recently, the main download page for Paltalk was this:
    http://www.paltalk.com/start_chatting.shtml
    But the content of that link recently changed, and now it has nothing but links for the 9.8 download. (strange)

    The main download page (as far as I know) has changed to this link:
    http://www.paltalk.com/download.php?refc=83190

    It offers the current 9.9 version, plus a version that is bundled with some sort of Norton component. “PC Checkup”. Is this bundled version v10? Im not a fan of downloading anything with nortons tied to it.

  4. RichEdit20W hence the “W” meaning Wide string I think it might have been RIchEdit20A before which “A” stands for Ansi Strings, Wide Strings is unicode meaning instead of 1 byte for each char it now has 2 bytes, which also means its double the size of Ansi and terminates with #0

  5. Well … it’s just the beta. 🙄 So they might change in the official version.
    I was not able to send UTf8 code, but able to send english text to chatroom via RichText32W 💡

  6. Wow … new paltalk? Unique code is awesome, it looks like that it couldn’t take UTF8 unicode 😐

    Just tried the new Paltalk, couldn’t find anything new accept the file size is bigger, and some new User Interface icons/backgrounds.

  7. @NVYE wrote:

    Wow … new paltalk? Unique code is awesome, it looks like that it couldn’t take UTF8 unicode :|.

    The version 10 Build 282 fully support Unicode (UTF-8), but build 384 does not

  8. Besides the change to richedit20W mentioned by winter, two other changes of interest to developers are the index of the send text and read text windows. Which are now 2 and 3 respectively.
    @Departure wrote:

    Wow just when you thought Paltalk couldn’t get anymore BLOATED

    hahaha I couldnt agree more. I was laughing hard over the spinning Pal logo on the login window also.

  9. @winter wrote:

    The version 10 Build 282 fully support Unicode (UTF-8), but build 384 does not

    That’s odd … why older version supported UTF8 and new version didn’t. 🙄

  10. @winter wrote:

    The version 10 Build 282 fully support Unicode (UTF-8), but build 384 does not

    I’ve been testing with build 384 and it does support unicode.

  11. @String wrote:

    @winter wrote:

    The version 10 Build 282 fully support Unicode (UTF-8), but build 384 does not

    I’ve been testing with build 384 and it does support unicode.

    Hi,
    I dont know what Unicode Software you are using, but I try with “Character Map” of windows then select the font Tahoma, copy one unicode then paste to room or PM (in the Text Setup | Language Support of Paltalk, selected UTF-8).
    After click SEND button, the character not same.
    You can try with this character: Ã ڛ

  12. What ever you type or paste into the room is sent as font Arial. If you try to paste in a font code for say Tahoma, it will be changed to Arial. But I see what you mean, I’m unable to send the character you posted above either.It only sends Ã.

    Try setting you computers regional settings to match the language your trying to send.

  13. It seems I am unable to type hebrew as I did before.
    I do have hebrew enforced on non unicode programs which may be a problem I will try to disable it, but I do need it for applications like notepad.

  14. Chike, did you try messing with the settings under Setup Preferences / Text Setup? There is a combobox with several languages to choose from there. Windows Hebrew is one of the choices.

  15. @String wrote:

    Is this text that is being sent via a program?

    No I type it. And why would they need support for other languages if they support UTF8.

  16. I have had requests from my friends to update my programs to work under Pal 10.
    All I need to do is to hold the mic button down release the mic button and send text into the chatroom and IM windows.
    Does anybody have any updated code for these?

    Thanks

  17. ‘@ Rontic – Read this entire thread. The answers to most of your questions are there. As far as the mic locking code, it appears to be unchanged and should work with 10.

  18. @winter wrote:

    No more Language Support option in Paltalk 10 Beta Build 386

    Yeah, I noticed that. Its window title has also changed from Paltalk Scene beta to Paltalk Messenger beta

  19. @Rontic wrote:

    I have had requests from my friends to update my programs to work under Pal 10.
    All I need to do is to hold the mic button down release the mic button and send text into the chatroom and IM windows.
    Does anybody have any updated code for these?

    Thanks

    so if you got a request to update why dont you update them? I mean after all you wouldn’t want people thinking it was your own work when it wasn’t right? so your best off just doing it your self, like you did at the start…

  20. I’m having problems in Pal 10 reading lines. It happens now and then and for spurts that em_getline will return 0 characters even though there is a line there and em_linelength shows the correct number of characters too. It happens most often when the line has several color switches. I’ve googled everywhere and I can’t see why em_getline would return 0 unless I was trying to read a line that isn’t there, but the line is there. Any ideas? Or any alternatives for reading lines from the paltalk screen?
    Also I’m using the ascii version of sendmessage for em_getline. That seems to work but the textbox is unicode I thought so I don’t know why it works.

  21. When the window buffer is full (around 250k charachters if I remember correctly), paltalk start deleting lines from the top.
    There is no full proof way around it unless you subclass the text window.
    I once suggested a way to minimize line lose, try searching for it.

    Alternative is to inject your code in pal, but comunication with application is complicated.

  22. Yeah I already use something like the method you suggested and clear the buffer at 200k. I double check that pal isn’t removing lines because I’m printing out the line numbers as I read each line and there is a steady progression in line numbers.
    If I get too frustrated I’ll have to learn injection.
    Thanks.

Leave a Reply

You must Register or Login to comment on Paltalk version 10