This topic contains 2 replies, has 2 voices, and was last updated by Avatar of ChiNa-Man ChiNa-Man 1 year, 1 month ago.

1 Star2 Stars3 Stars4 Stars5 Stars Rate it first!
Loading ... Loading ...
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #14751
    Avatar of ChiNa-Man
    ChiNa-Man
    Keymaster

    So here I am after creating a few Skype Tools using the SKYPE4COM’s developer Tool Package! Now for months I been having this error on my friends Computer, and a few other people. But not on my part.

    I was thinking that its about time I publish a few of them and asking for advice.. And
    Why am I getting this error?

    Here is the Link for the Skype Auto Responder: http://www.imfiles.com/skype-auto-responder-bot-t43490/

    The Auto Responder that I created for Skype few months ago worked fine for me, But just for me. Right now it works only on my Computer. I think the reason why is that my Computer is fully updated with all the NET and the Tools that I need, But I was testing it on a friends computer and he got this error.

    I really dont get this. Maybe I didnt register the DLL or Maybe something was missing on his part.
    So I started downloading and Installing all the Latest versions of Net.Framework, incl 4.0 Client profile for him. He already had the 4.0 version and 3.5 + Client Profile. We even Installed 4.5 for him a few days ago.
    But he still kept getting the error.nd another surprise happend to me, when I was I running the software using the “Run As Administrator”.

    And today I got another suprise, I got the same exact error today when I was trying to run it as Administrator.
    Now I also tried to set the target for my debug to “ANY CPU”.. When I did that then it was all good again. And since everything is running as it should. I did also check and set my “Advance Compile Options” to NET 4.0 from 4.0 Client Profile, but still kept getting the error when runnd as Administrator.

    This is the only reason why I havnt published my Skype Projects and Tools untill now, and I have created a bunch and I dont like that my products are not running correct!

    Hope I can get some advice about why is this thing giving these errors.

    Below is the Error appearing on the Error Box.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.Runtime.InteropServices.COMException (0×80040154): Retrieving the COM class factory for component with CLSID {830690FC-BF2F-47A6-AC2D-330BCB402664} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0×80040154 (REGDB_E_CLASSNOTREG)).
    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
    at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
    at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
    at System.Activator.CreateInstance(Type type, Boolean nonPublic)
    at System.Activator.CreateInstance(Type type)
    at WindowsApplication1.skypeAutowrite.skypeAutoWrite(Object sender, EventArgs e) in C:UsersTopBillDocumentsAuto-Responder (Auto Bot)Form1.vb:line 6
    at System.EventHandler.Invoke(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ContainerControl.WndProc(Message& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll


    Skype – Auto Responder Bot
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/TopBill/Documents/Auto-Responder%20(Auto%20Bot)/bin/Debug/Skype%20-%20Auto%20Responder%20.exe


    Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 11.0.50709.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll


    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll


    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll


    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18036 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


    System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll


    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll


    System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll



    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:



    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    #36526
    Avatar of NVYE
    NVYE
    Keymaster

    I think I have experience this … Some developers have a version of auto increment on each build … so each build has it own COM reg ID. Your friend might have a old version of COM object or new version of it. In order for the program to work you must have a same version … so once you build make sure you attach your SKYPE4COM DLL with your application to make it work.

    #36527
    Avatar of ChiNa-Man
    ChiNa-Man
    Keymaster

    @NVYE wrote:

    I think I have experience this … Some developers have a version of auto increment on each build … so each build has it own COM reg ID. Your friend might have a old version of COM object or new version of it. In order for the program to work you must have a same version … so once you build make sure you attach your SKYPE4COM DLL with your application to make it work.

    Thank you NVYE, for the response. For a strange reason the product is suddenly working on his computer!

    Let me remind you that he lives in Russia and his Windows in Russian Language, Incl the NET.FRAMEWORKs he downloads is in Russian Language! I dont know if NET.FRAMEWORKS from with other Languages will fit our Programs? What you say to that NVYE? I know you have experience with making your last product (Greeter) work with other Windows with Different languages. Hope you could put some advice in this convo..

    The only thing that isnt fix is when we use the RUN as Administrator it gives us the error! But befor It didnt even work as normal on his computer!

    I guess its because I recently installed many new updates for my Visual Basic that was required by Windows Update, and lots of other Net and Com stuff have been added! So maybe because I was missing a .com or .net update.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.