How to configure your router to allow fast BitTorrent downlo

Viewing 1 post (of 1 total)
  • Author
  • #191660

    There sure is a lot of people that have adopted BitTorrent as the tool of choice to download movies and TV shows. However if you are using a network router you might be facing painstainkingly slow downloads (of around 10Kbps) because of a network configuration not properly set. Some think it’s a client thing and switch from one to another with no results.

    The problem’s cause is that some ports on your router are blocked by default and the solution is to open them up. We had to find it the hard way because lots of FAQ lists out there don’t give enough detail on how to solve this issue. This simple but useful tip will increase download throughput from 10 to ~240 Kbps.

    NOTE: The specific example below considers a Linksys router, but that should work for any other manufacturers (e.g. D-Link, Netgear, etc.). Our Linksys router is the Wireless-G WRT54G. Other models might have a slight different user interface but should be very similar.
    1) Open a web browser window and type your Default Gateway IP number in the address bar. It should be in most cases.
    2) To login leave username blank and type admin for the password (unless you have changed it before which is always advisable)
    3) Find the section that says Port Range Forwarding or similar
    4) Add in the port range 6881-6889 for Torrent files
    5) Make sure you check both protocol boxes TCP and UDP as well as the Enable setting.
    Linksys config
    6) Have the forward address set as your internal IP address in our case. To find yours Go to Start -> Run and type in cmd.
    This will open a DOS window. Type the command IPCONFIG and look for your ‘IP Address’.

    7) Confirm and submit all the changes and that will probably work.
    If you’ve been through this share your experience here. If you have different routers or versions of Linksys and there’s something different let us know how to configure it.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.